projects using libt2n-codegen must include the makefile snippet themselves.
[libt2n] / example-codegen / Makefile.am
index ca49cb8..d5670f3 100644 (file)
@@ -1,3 +1,7 @@
+# not a GNU package. You can remove this line, if
+# you have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign 1.4
+
 INCLUDES = @LIBT2N_CFLAGS@
 LDADD = @LIBT2N_LIBS@
 
@@ -38,10 +42,10 @@ TESTS = test
 
 EXTRA_DIST = $(TESTS) configure.in
 
-# we have got an old automake version (1.4-p5) which doesn't support nodist_
-# => you might want to use the dist-hook to remove generated files
-dist-hook:
-       rm -vf $(foreach i, $(BUILT_SOURCES), $(distdir)/$(i))
-
-# if you use codegen you should add the next line at the end
-@LIBT2N_CODEGEN_MAKESNIPPET@
+# if you use libt2n-codegen you should add this
+# (i did not find a nice way to let libt2n install this makefile snippet
+# and let projects using libt2n use the installed version.
+# the core of the problem is:
+# the makefile snippet is already needed when automake is run
+# => no way to let configure locate the snippet)
+include codegen.make