projects using libt2n-codegen must include the makefile snippet themselves.
[libt2n] / example-codegen / Makefile.am
index 5deff2e..d5670f3 100644 (file)
@@ -1,24 +1,51 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
+# not a GNU package. You can remove this line, if
+# you have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign 1.4
 
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+INCLUDES = @LIBT2N_CFLAGS@
+LDADD = @LIBT2N_LIBS@
 
-libclient_la_SOURCES = codegen_client.cpp
-noinst_LTLIBRARIES = libclient.la
+# list your command groups
+CMDGROUPS = default other
 
-client_SOURCES = client.cpp
-client_LDADD = $(LDADD) libclient.la
+# for each command group list the files to parse for LIBT2N_EXPORT
+default_GROUP = default.cpp
+# example of a command group using multiple cpp files
+other_GROUP = other-1.cpp other-2.cpp
+
+# headers declaring data types used as rpc arguments must be listed manually
+# (in this example the class Foo)
+include_HEADERS = foo.hxx
 
-server_SOURCES = server.cpp codegen_server.cpp foo.hxx
+# unfortunately we can't set those from variables
+# because they are parsed by automake
+# and we can't use noinst since our automake version is to old
+# (see dist-hook in codegen.make)
+
+libdefault_la_SOURCES = default_client.cpp
+libother_la_SOURCES = other_client.cpp
+lib_LTLIBRARIES = libdefault.la libother.la
+
+# build an example server and client
+client_SOURCES = client.cpp
+client_LDADD = $(LDADD) libdefault.la libother.la
 
 noinst_PROGRAMS = client server
 
-codegen.stamp: server.hxx $(top_builddir)/codegen/codegen
-       cp $(top_srcdir)/codegen/codegen-stubhead.hxx codegen_common.hxx
-# todo use tmp file for server.xml
-       gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $< -fxml=server.xml
-       $(top_builddir)/codegen/codegen $< server.xml codegen_
-       touch $@
+server_SOURCES = \
+       server.cpp $(other_GROUP) $(default_GROUP) \
+       other_server.cpp default_server.cpp
 
-codegen_common.hxx codegen_common.cpp codegen_client.hxx codegen_client.cpp codegen_server.cpp: codegen.stamp
+# test script
 
 TESTS = test
+
+EXTRA_DIST = $(TESTS) configure.in
+
+# if you use libt2n-codegen you should add this
+# (i did not find a nice way to let libt2n install this makefile snippet
+# and let projects using libt2n use the installed version.
+# the core of the problem is:
+# the makefile snippet is already needed when automake is run
+# => no way to let configure locate the snippet)
+include codegen.make