added variables to pc file
[libt2n] / example-codegen / Makefile.am
index 30b8d8d..cabf100 100644 (file)
@@ -1,4 +1,3 @@
-# todo: remove codegen include path (codegen-stubhead.hxx will be removed)
 INCLUDES = @LIBT2N_CPPFLAGS@
 LDADD = @LIBT2N_LIBS@
 
@@ -37,6 +36,12 @@ server_SOURCES = \
 
 TESTS = test
 
-EXTRA_DIST = $(TESTS)
+EXTRA_DIST = $(TESTS) configure.in
 
-include @LIBT2N_CODEGEN_MAKESNIPPET@
+# we have got an old automake version (1.4-p5) which doesn't support nodist_
+# => you might want to use the dist-hook to remove generated files
+dist-hook:
+       rm -vf $(foreach i, $(BUILT_SOURCES), $(distdir)/$(i))
+
+# if you use codegen you should add the next line at the end
+@LIBT2N_CODEGEN_MAKESNIPPET@