rename LIBT2N_CPPFLAGS to LIBT2N_CFLAGS since this is the variable defined by PKG_CHE...
[libt2n] / example-codegen / Makefile.am
index d1134fe..ca49cb8 100644 (file)
@@ -1,5 +1,5 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+INCLUDES = @LIBT2N_CFLAGS@
+LDADD = @LIBT2N_LIBS@
 
 # list your command groups
 CMDGROUPS = default other
@@ -36,6 +36,12 @@ server_SOURCES = \
 
 TESTS = test
 
-EXTRA_DIST = $(TESTS)
+EXTRA_DIST = $(TESTS) configure.in
 
-include $(top_srcdir)/codegen/codegen.make
+# we have got an old automake version (1.4-p5) which doesn't support nodist_
+# => you might want to use the dist-hook to remove generated files
+dist-hook:
+       rm -vf $(foreach i, $(BUILT_SOURCES), $(distdir)/$(i))
+
+# if you use codegen you should add the next line at the end
+@LIBT2N_CODEGEN_MAKESNIPPET@