rename LIBT2N_CPPFLAGS to LIBT2N_CFLAGS since this is the variable defined by PKG_CHE...
[libt2n] / example-codegen / Makefile.am
index 1911f20..ca49cb8 100644 (file)
@@ -1,7 +1,4 @@
-# if you use codegen you should add the next line
-@LIBT2N_CODEGEN_MAKESNIPPET@
-
-INCLUDES = @LIBT2N_CPPFLAGS@
+INCLUDES = @LIBT2N_CFLAGS@
 LDADD = @LIBT2N_LIBS@
 
 # list your command groups
@@ -39,4 +36,12 @@ server_SOURCES = \
 
 TESTS = test
 
-EXTRA_DIST = $(TESTS)
+EXTRA_DIST = $(TESTS) configure.in
+
+# we have got an old automake version (1.4-p5) which doesn't support nodist_
+# => you might want to use the dist-hook to remove generated files
+dist-hook:
+       rm -vf $(foreach i, $(BUILT_SOURCES), $(distdir)/$(i))
+
+# if you use codegen you should add the next line at the end
+@LIBT2N_CODEGEN_MAKESNIPPET@