(no commit message)
[libt2n] / example-codegen / Makefile.am
index a4195d4..b2c51de 100644 (file)
@@ -1,6 +1,6 @@
 # not a GNU package. You can remove this line, if
-# have all needed files, that a GNU package needs
-AUTOMAKE_OPTIONS = foreign 1.4
+# you have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign
 
 INCLUDES = @LIBT2N_CFLAGS@
 LDADD = @LIBT2N_LIBS@
@@ -42,13 +42,10 @@ TESTS = test
 
 EXTRA_DIST = $(TESTS) configure.in
 
-# we have got an old automake version (1.4-p5) which doesn't support nodist_
-# => you might want to use the dist-hook to remove generated files
-dist-hook:
-       rm -vf $(foreach i, $(LIBT2N_CODEGEN_BUILT), $(distdir)/$(i))
-
 # if you use libt2n-codegen you should add this
-@LIBT2N_CODEGEN_MAKESNIPPET@
-
-CLEANFILES = $(LIBT2N_SUGGESTED_CLEANFILES)
-
+# (i did not find a nice way to let libt2n install this makefile snippet
+# and let projects using libt2n use the installed version.
+# the core of the problem is:
+# the makefile snippet is already needed when automake is run
+# => no way to let configure locate the snippet)
+include codegen.make