(no commit message)
[libt2n] / example-codegen / Makefile.am
index 30b8d8d..b2c51de 100644 (file)
@@ -1,5 +1,8 @@
-# todo: remove codegen include path (codegen-stubhead.hxx will be removed)
-INCLUDES = @LIBT2N_CPPFLAGS@
+# not a GNU package. You can remove this line, if
+# you have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign
+
+INCLUDES = @LIBT2N_CFLAGS@
 LDADD = @LIBT2N_LIBS@
 
 # list your command groups
@@ -37,6 +40,12 @@ server_SOURCES = \
 
 TESTS = test
 
-EXTRA_DIST = $(TESTS)
+EXTRA_DIST = $(TESTS) configure.in
 
-include @LIBT2N_CODEGEN_MAKESNIPPET@
+# if you use libt2n-codegen you should add this
+# (i did not find a nice way to let libt2n install this makefile snippet
+# and let projects using libt2n use the installed version.
+# the core of the problem is:
+# the makefile snippet is already needed when automake is run
+# => no way to let configure locate the snippet)
+include codegen.make