CLEANFILES must be listed directly, too - otherwise automake will not use it :-(
[libt2n] / example-codegen / Makefile.am
index 28f9e75..a4195d4 100644 (file)
@@ -1,56 +1,54 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
+# not a GNU package. You can remove this line, if
+# have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign 1.4
 
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+INCLUDES = @LIBT2N_CFLAGS@
+LDADD = @LIBT2N_LIBS@
 
-libdefault_la_SOURCES = default_client.cpp
-libother_la_SOURCES = other_client.cpp
-noinst_LTLIBRARIES = libdefault.la libother.la
+# list your command groups
+CMDGROUPS = default other
 
+# for each command group list the files to parse for LIBT2N_EXPORT
+default_GROUP = default.cpp
+# example of a command group using multiple cpp files
+other_GROUP = other-1.cpp other-2.cpp
 
-CMDGROUPS = default other
+# headers declaring data types used as rpc arguments must be listed manually
+# (in this example the class Foo)
+include_HEADERS = foo.hxx
+
+# unfortunately we can't set those from variables
+# because they are parsed by automake
+# and we can't use noinst since our automake version is to old
+# (see dist-hook in codegen.make)
+
+libdefault_la_SOURCES = default_client.cpp
+libother_la_SOURCES = other_client.cpp
+lib_LTLIBRARIES = libdefault.la libother.la
 
+# build an example server and client
 client_SOURCES = client.cpp
 client_LDADD = $(LDADD) libdefault.la libother.la
 
-server_SOURCES = server.cpp \
-       other.cpp other_server.cpp \
-       default.cpp default_server.cpp \
-       foo.hxx
-
 noinst_PROGRAMS = client server
 
-codegen.stamp: default.cpp other.cpp $(top_builddir)/codegen/codegen
-# assuming we have some unix like shell
-       for i in $(CMDGROUPS); do \
-               cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $${i}_common.hxx; \
-               cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $${i}_server.hxx; \
-       done
-# todo use tmp file for xml file
-       for i in $(CMDGROUPS); do \
-               gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i}.cpp -fxml=$${i}.xml; \
-               $(top_builddir)/codegen/codegen $${i}.cpp $${i}.xml $${i}; \
-       done; touch $@
+server_SOURCES = \
+       server.cpp $(other_GROUP) $(default_GROUP) \
+       other_server.cpp default_server.cpp
 
-DEFAULT_GENERATED = default_common.hxx default_common.cpp default_client.hxx default_client.cpp default_server.hxx default_server.cpp
-$(DEFAULT_GENERATED): codegen.stamp
-
-OTHER_GENERATED = other_common.hxx other_common.cpp other_client.hxx other_client.cpp other_server.hxx other_server.cpp
-$(OTHER_GENERATED): codegen.stamp
-
-BUILT_SOURCES = $(DEFAULT_GENERATED) $(OTHER_GENERATED)
+# test script
 
 TESTS = test
 
-CLEANFILES = codegen.stamp
-
-# TODO:
-# howto generate Makefile(.in) from something like this:
+EXTRA_DIST = $(TESTS) configure.in
 
-# CMDGROUPS = default other
+# we have got an old automake version (1.4-p5) which doesn't support nodist_
+# => you might want to use the dist-hook to remove generated files
+dist-hook:
+       rm -vf $(foreach i, $(LIBT2N_CODEGEN_BUILT), $(distdir)/$(i))
 
-# default_SOURCES = default-1.cpp default-2.cpp
-# other_SOURCES = other.cpp
+# if you use libt2n-codegen you should add this
+@LIBT2N_CODEGEN_MAKESNIPPET@
 
-# TESTS = test
+CLEANFILES = $(LIBT2N_SUGGESTED_CLEANFILES)
 
-# server_SOURCES = server.cpp default foo.hxx