use pkgincludedir for headers (to avoid file name collisions), renamed LIBT2N_CLIENT_...
[libt2n] / example-codegen / Makefile.am
index b11e881..1911f20 100644 (file)
@@ -1,31 +1,42 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
+# if you use codegen you should add the next line
+@LIBT2N_CODEGEN_MAKESNIPPET@
 
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+INCLUDES = @LIBT2N_CPPFLAGS@
+LDADD = @LIBT2N_LIBS@
+
+# list your command groups
+CMDGROUPS = default other
+
+# for each command group list the files to parse for LIBT2N_EXPORT
+default_GROUP = default.cpp
+# example of a command group using multiple cpp files
+other_GROUP = other-1.cpp other-2.cpp
+
+# headers declaring data types used as rpc arguments must be listed manually
+# (in this example the class Foo)
+include_HEADERS = foo.hxx
+
+# unfortunately we can't set those from variables
+# because they are parsed by automake
+# and we can't use noinst since our automake version is to old
+# (see dist-hook in codegen.make)
 
 libdefault_la_SOURCES = default_client.cpp
 libother_la_SOURCES = other_client.cpp
-noinst_LTLIBRARIES = libdefault.la libother.la
+lib_LTLIBRARIES = libdefault.la libother.la
 
+# build an example server and client
 client_SOURCES = client.cpp
 client_LDADD = $(LDADD) libdefault.la libother.la
 
-server_SOURCES = server.cpp other_server.cpp default_server.cpp other.cpp default.cpp foo.hxx
-
 noinst_PROGRAMS = client server
 
-codegen.stamp: default.cpp other.cpp $(top_builddir)/codegen/codegen
-# assuming we have some unix like shell
-       for i in default other; do \
-               cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $${i}_common.hxx; \
-               cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $${i}_server.hxx; \
-       done
-# todo use tmp file for xml file
-       for i in default other; do \
-               gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i}.cpp -fxml=$${i}.xml; \
-               $(top_builddir)/codegen/codegen $${i}.cpp $${i}.xml $${i}; \
-       done; touch $@
-
-default_common.hxx default_common.cpp default_client.hxx default_client.cpp default_server.hxx default_server.cpp: codegen.stamp
-other_common.hxx other_common.cpp other_client.hxx other_client.cpp other_server.hxx other_server.cpp: codegen.stamp
+server_SOURCES = \
+       server.cpp $(other_GROUP) $(default_GROUP) \
+       other_server.cpp default_server.cpp
+
+# test script
 
 TESTS = test
+
+EXTRA_DIST = $(TESTS)