use pkgincludedir for headers (to avoid file name collisions), renamed LIBT2N_CLIENT_...
[libt2n] / example-codegen / Makefile.am
index 3531289..1911f20 100644 (file)
@@ -1,23 +1,42 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
+# if you use codegen you should add the next line
+@LIBT2N_CODEGEN_MAKESNIPPET@
 
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+INCLUDES = @LIBT2N_CPPFLAGS@
+LDADD = @LIBT2N_LIBS@
 
-libclient_la_SOURCES = codegen_client.cpp
-noinst_LTLIBRARIES = libclient.la
+# list your command groups
+CMDGROUPS = default other
 
-client_SOURCES = client.cpp
-client_LDADD = $(LDADD) libclient.la
+# for each command group list the files to parse for LIBT2N_EXPORT
+default_GROUP = default.cpp
+# example of a command group using multiple cpp files
+other_GROUP = other-1.cpp other-2.cpp
+
+# headers declaring data types used as rpc arguments must be listed manually
+# (in this example the class Foo)
+include_HEADERS = foo.hxx
+
+# unfortunately we can't set those from variables
+# because they are parsed by automake
+# and we can't use noinst since our automake version is to old
+# (see dist-hook in codegen.make)
 
-server_SOURCES = server.cpp codegen_server.cpp
+libdefault_la_SOURCES = default_client.cpp
+libother_la_SOURCES = other_client.cpp
+lib_LTLIBRARIES = libdefault.la libother.la
+
+# build an example server and client
+client_SOURCES = client.cpp
+client_LDADD = $(LDADD) libdefault.la libother.la
 
 noinst_PROGRAMS = client server
 
-all-local: server.xml
+server_SOURCES = \
+       server.cpp $(other_GROUP) $(default_GROUP) \
+       other_server.cpp default_server.cpp
+
+# test script
 
-client.cpp codegen_common.hxx codegen_common.cpp codegen_client.hxx codegen_client.cpp codegen_server.cpp: server.xml
+TESTS = test
 
-server.xml: server.cpp $(top_builddir)/codegen/codegen
-       cp $(top_srcdir)/codegen/codegen-stubhead.hxx codegen_common.hxx
-       gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) server.hxx -fxml=tmpserver.xml
-       $(top_builddir)/codegen/codegen tmpserver.xml codegen_
-       mv tmpserver.xml server.xml
+EXTRA_DIST = $(TESTS)