try to find workaround for old automake
[libt2n] / example-codegen / Makefile.am
index d4dae59..00aaac7 100644 (file)
@@ -1,57 +1,62 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
+# not a GNU package. You can remove this line, if
+# you have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign
 
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+INCLUDES = @LIBT2N_CFLAGS@
+LDADD = @LIBT2N_LIBS@
 
+# list your command groups
 CMDGROUPS = default other
 
+# for each command group list the files to parse for LIBT2N_EXPORT
 default_GROUP = default.cpp
+# example of a command group using multiple cpp files
 other_GROUP = other-1.cpp other-2.cpp
 
+# headers declaring data types used as rpc arguments must be listed manually
+# (in this example the class Foo)
+include_HEADERS = foo.hxx
+
 # unfortunately we can't set those from variables
 # because they are parsed by automake
 
-libdefault_la_SOURCES = default_client.cpp
-libother_la_SOURCES = other_client.cpp
-noinst_LTLIBRARIES = libdefault.la libother.la
+# we would like to use nodist_ here but our automake is to old
+# nodist_libdefault_la_SOURCES = default_client.cpp
+# nodist_libother_la_SOURCES = other_client.cpp
+
+# using objects as workaround
+libdefault_la_OBJECTS += default_client.lo
+#libdefault_la_SOURCES = default_client.cpp
+libother_la_OBJECTS += other_client.lo
+#libother_la_SOURCES = other_client.cpp
+lib_LTLIBRARIES = libdefault.la libother.la
 
+# build an example server and client
 client_SOURCES = client.cpp
 client_LDADD = $(LDADD) libdefault.la libother.la
 
-server_SOURCES = server.cpp \
-       $(other_GROUP) other_server.cpp \
-       $(default_GROUP) default_server.cpp \
-       foo.hxx
-
 noinst_PROGRAMS = client server
 
+# we would like to use nodist_ here but our automake is to old
+# nodist_server_SOURCES = other_server.cpp default_server.cpp
 
-# always the same:
-
-#IFILES=$(foreach i, $(CMDGROUPS), $(foreach j, $($(i)_GROUP), $(j)))
-STAMPS=$(CMDGROUPS:=.stamp)
+server_LDADD = $(LDADD) other_server.$(OBJEXT) default_server.$(OBJEXT)
 
-GROUPDEP_FILES =  $(foreach i, $(CMDGROUPS), .deps/group_$(i).P)
--include $(GROUPDEP_FILES)
+server_SOURCES = \
+       server.cpp $(other_GROUP) $(default_GROUP)
+#      other_server.cpp default_server.cpp
 
-.deps/group_%.P : Makefile.am
-       echo $@ : $($*_GROUP) > .deps/group_$*.P
 
-%.stamp : .deps/group_%.P $(top_builddir)/codegen/codegen Makefile.am
-# assuming we have some unix like shell (maybe even bash)
-       echo BUILT_SOURCES: $(BUILT_SOURCES)
-       cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $*_common.hxx;
-       cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $*_server.hxx;
-# todo use tmp file for xml file
-       for i in $($*_GROUP); do \
-               gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i} -fxml=$${i%*.cpp}.xml; \
-       done; \
-       $(top_builddir)/codegen/codegen $*.cpp $* $($*_GROUP:.cpp=.xml) && touch $@
-
-# assuming we have gnu make?
-BUILT_SOURCES = $(foreach i, $(CMDGROUPS), $(foreach j, _common.hxx _common.cpp _client.hxx _client.cpp _server.hxx _server.cpp, $(i)$(j)) )
-
-$(BUILT_SOURCES) : $(STAMPS)
+# test script
 
 TESTS = test
 
-CLEANFILES = $(BUILT_SOURCES) $(STAMPS)
+EXTRA_DIST = $(TESTS) configure.in
+
+# if you use libt2n-codegen you should add this
+# (i did not find a nice way to let libt2n install this makefile snippet
+# and let projects using libt2n use the installed version.
+# the core of the problem is:
+# the makefile snippet is already needed when automake is run
+# => no way to let configure locate the snippet)
+include codegen.make