try to find workaround for old automake
[libt2n] / example-codegen / Makefile.am
index d1134fe..00aaac7 100644 (file)
@@ -1,5 +1,9 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+# not a GNU package. You can remove this line, if
+# you have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign
+
+INCLUDES = @LIBT2N_CFLAGS@
+LDADD = @LIBT2N_LIBS@
 
 # list your command groups
 CMDGROUPS = default other
@@ -15,11 +19,16 @@ include_HEADERS = foo.hxx
 
 # unfortunately we can't set those from variables
 # because they are parsed by automake
-# and we can't use noinst since our automake version is to old
-# (see dist-hook in codegen.make)
 
-libdefault_la_SOURCES = default_client.cpp
-libother_la_SOURCES = other_client.cpp
+# we would like to use nodist_ here but our automake is to old
+# nodist_libdefault_la_SOURCES = default_client.cpp
+# nodist_libother_la_SOURCES = other_client.cpp
+
+# using objects as workaround
+libdefault_la_OBJECTS += default_client.lo
+#libdefault_la_SOURCES = default_client.cpp
+libother_la_OBJECTS += other_client.lo
+#libother_la_SOURCES = other_client.cpp
 lib_LTLIBRARIES = libdefault.la libother.la
 
 # build an example server and client
@@ -28,14 +37,26 @@ client_LDADD = $(LDADD) libdefault.la libother.la
 
 noinst_PROGRAMS = client server
 
+# we would like to use nodist_ here but our automake is to old
+# nodist_server_SOURCES = other_server.cpp default_server.cpp
+
+server_LDADD = $(LDADD) other_server.$(OBJEXT) default_server.$(OBJEXT)
+
 server_SOURCES = \
-       server.cpp $(other_GROUP) $(default_GROUP) \
-       other_server.cpp default_server.cpp
+       server.cpp $(other_GROUP) $(default_GROUP)
+#      other_server.cpp default_server.cpp
+
 
 # test script
 
 TESTS = test
 
-EXTRA_DIST = $(TESTS)
+EXTRA_DIST = $(TESTS) configure.in
 
-include $(top_srcdir)/codegen/codegen.make
+# if you use libt2n-codegen you should add this
+# (i did not find a nice way to let libt2n install this makefile snippet
+# and let projects using libt2n use the installed version.
+# the core of the problem is:
+# the makefile snippet is already needed when automake is run
+# => no way to let configure locate the snippet)
+include codegen.make