try to find workaround for old automake
[libt2n] / example-codegen / Makefile.am
index 7a73932..00aaac7 100644 (file)
@@ -1,56 +1,62 @@
-INCLUDES = -I$(top_srcdir)/src @BOOST_CPPFLAGS@ @CPPUNIT_CFLAGS@ -I$(top_srcdir)/codegen
+# not a GNU package. You can remove this line, if
+# you have all needed files, that a GNU package needs
+AUTOMAKE_OPTIONS = foreign
 
-LDADD = $(top_builddir)/src/libt2n.la @BOOST_SERIALIZATION_LIB@ @BOOST_LDFLAGS@
+INCLUDES = @LIBT2N_CFLAGS@
+LDADD = @LIBT2N_LIBS@
 
+# list your command groups
 CMDGROUPS = default other
 
-libdefault_la_SOURCES = default_client.cpp
-libother_la_SOURCES = other_client.cpp
-noinst_LTLIBRARIES = libdefault.la libother.la
+# for each command group list the files to parse for LIBT2N_EXPORT
+default_GROUP = default.cpp
+# example of a command group using multiple cpp files
+other_GROUP = other-1.cpp other-2.cpp
 
-client_SOURCES = client.cpp
-client_LDADD = $(LDADD) libdefault.la libother.la
+# headers declaring data types used as rpc arguments must be listed manually
+# (in this example the class Foo)
+include_HEADERS = foo.hxx
 
-server_SOURCES = server.cpp \
-       other.cpp other_server.cpp \
-       default.cpp default_server.cpp \
-       foo.hxx
+# unfortunately we can't set those from variables
+# because they are parsed by automake
 
-noinst_PROGRAMS = client server
+# we would like to use nodist_ here but our automake is to old
+# nodist_libdefault_la_SOURCES = default_client.cpp
+# nodist_libother_la_SOURCES = other_client.cpp
 
+# using objects as workaround
+libdefault_la_OBJECTS += default_client.lo
+#libdefault_la_SOURCES = default_client.cpp
+libother_la_OBJECTS += other_client.lo
+#libother_la_SOURCES = other_client.cpp
+lib_LTLIBRARIES = libdefault.la libother.la
 
-# always the same:
-
-codegen.stamp: $(CMDGROUPS:%=%.cpp) $(top_builddir)/codegen/codegen
-# assuming we have some unix like shell
-       echo BUILT_SOURCES: $(BUILT_SOURCES)
-       for i in $(CMDGROUPS); do \
-               cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $${i}_common.hxx; \
-               cp -v $(top_srcdir)/codegen/codegen-stubhead.hxx $${i}_server.hxx; \
-       done
-# todo use tmp file for xml file
-       for i in $(CMDGROUPS); do \
-               gccxml $(DEFS) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS) $${i}.cpp -fxml=$${i}.xml; \
-               $(top_builddir)/codegen/codegen $${i}.cpp $${i}.xml $${i}; \
-       done; touch $@
+# build an example server and client
+client_SOURCES = client.cpp
+client_LDADD = $(LDADD) libdefault.la libother.la
 
-# assuming we have gnu make?
-BUILT_SOURCES = $(foreach i, $(CMDGROUPS), $(foreach j, _common.hxx _common.cpp _client.hxx _client.cpp _server.hxx _server.cpp, $(i)$(j)) )
+noinst_PROGRAMS = client server
 
-$(BUILT_SOURCES) : codegen.stamp
+# we would like to use nodist_ here but our automake is to old
+# nodist_server_SOURCES = other_server.cpp default_server.cpp
 
-TESTS = test
+server_LDADD = $(LDADD) other_server.$(OBJEXT) default_server.$(OBJEXT)
 
-CLEANFILES = $(BUILT_SOURCES) codegen.stamp
+server_SOURCES = \
+       server.cpp $(other_GROUP) $(default_GROUP)
+#      other_server.cpp default_server.cpp
 
-# TODO:
-# howto generate Makefile(.in) from something like this:
 
-# CMDGROUPS = default other
+# test script
 
-# default_SOURCES = default-1.cpp default-2.cpp
-# other_SOURCES = other.cpp
+TESTS = test
 
-# TESTS = test
+EXTRA_DIST = $(TESTS) configure.in
 
-# server_SOURCES = server.cpp default foo.hxx
+# if you use libt2n-codegen you should add this
+# (i did not find a nice way to let libt2n install this makefile snippet
+# and let projects using libt2n use the installed version.
+# the core of the problem is:
+# the makefile snippet is already needed when automake is run
+# => no way to let configure locate the snippet)
+include codegen.make