doxygen documentation cannot be built using a seperate build directory but we do...
[libt2n] / doc / Makefile.am
index c8180ce..c1297fe 100644 (file)
@@ -8,5 +8,8 @@ endif
 
 all: $(MANUALS)
 
-html/index.html: $(top_srcdir)/src/*.cpp $(top_srcdir)/src/*.hxx $(top_srcdir)/codegen/*.hxx $(top_srcdir)/codegen/*.cpp
-       $(DOXYGEN)
+# todo: separate build dir still doesn't work
+html/index.html: $(top_srcdir)/src/*.cpp $(top_srcdir)/src/*.hxx $(top_srcdir)/codegen/*.hxx $(top_srcdir)/codegen/*.cpp $(srcdir)/index.doc
+       if test -f header.html; then $(DOXYGEN); else echo "FIXME: doxygen documentation cannot be built using a seperate build directory"; fi
+
+EXTRA_DIST = index.doc header.html