we do not want to ship .svn directories
[libt2n] / doc / Makefile.am
index c5c4615..01bc533 100644 (file)
@@ -8,5 +8,8 @@ endif
 
 all: $(MANUALS)
 
-html/index.html: $(top_srcdir)/src/*.cpp $(top_srcdir)/src/*.hxx
-       $(DOXYGEN)
+# todo: separate build dir still doesn't work
+html/index.html: $(top_srcdir)/src/*.cpp $(top_srcdir)/src/*.hxx $(top_srcdir)/codegen/*.hxx $(top_srcdir)/codegen/*.cpp $(srcdir)/index.doc
+       $(DOXYGEN) 
+
+EXTRA_DIST = index.doc