docu updates
[libt2n] / codegen / Makefile.am
index 2463620..998b67b 100644 (file)
@@ -5,12 +5,13 @@ libt2n_codegen_SOURCES = main.cpp
 
 bin_PROGRAMS = libt2n-codegen
 
-pkgdata_DATA = clientlib.pc.in codegen.make
+pkgdata_DATA = clientlib.pc.in
 
 # needed because we use old automake not supporting dist_ prefix
 
 EXTRA_DIST = $(pkgdata_DATA)
 
-# todo: do we really want to install it
-# (maybe it would be better to install a copy with each client lib?)
-include_HEADERS = codegen-stubhead.hxx
+# do we really want to install it?
+# maybe it would be better to install a copy with each client lib or let codegen insert the code?
+# on the other hand the generated libraries depend on the libt2n headers anyway
+pkginclude_HEADERS = codegen-stubhead.hxx