libftdi: (gerd) add a real libftdi with autoconf stuff, remove include of usb.h in...
[libftdi] / libftdi.spec
1 Summary:   Library to program and control the FTDI USB controller
2 Name:      libftdi
3 Version:   ##VERSION##
4 Release:   1
5 Copyright: LGPL
6 Group:     System Environment/Libraries
7 Vendor:    Intra2net AG
8 Source:    %{name}-%{version}.tar.gz
9 Buildroot: /tmp/%{name}-%{version}-root
10 Requires:  libusb
11 Prefix:    /usr
12
13 %package   devel
14 Summary:   Header files and static libraries for libftdi
15 Group:     Development/Libraries
16 Requires:  libftdi = %{version}, libusb-devel
17
18 %description 
19 Library to program and control the FTDI USB controller
20
21 %description devel
22 Header files and static libraries for libftdi
23
24 %prep
25 %setup -q
26
27 %build
28 ./configure --prefix=%{prefix}
29 make
30
31 %install
32 make DESTDIR=$RPM_BUILD_ROOT install
33
34 %clean
35 rm -fr $RPM_BUILD_ROOT
36
37 %files
38 %defattr(-,root,root)
39 %{prefix}/lib/libftdi.so*
40
41 %files devel
42 %defattr(-,root,root)
43 %{prefix}/lib/libftdi.*a
44 %{prefix}/include/*.h